Results 1 to 21 of 21

Thread: 350 TBI misfire, running rich, popping back through TBI

  1. #1
    Senior Member cj7's Avatar
    Join Date
    Jul 2013
    Location
    San Antonio, Texas
    Posts
    3,428
    Likes
    614
    Liked 128 Times in 118 Posts
    Blog Entries
    2

    350 TBI misfire, running rich, popping back through TBI

    so once again I am having issues with my TBI 350. took 45 minutes yesterday just to get it running good enough to get away from the trailer. once out on the trails it seemed to do well enough for a while, then it would act like its starving for fuel, running rich, and generally like shit. even set the air filter on fire.. (story in itself). shut it off for 5 minutes or so, maybe a bit longer and it would run fine again for a few minutes. SAK5 said he had a very similar issue once and replaced the TPS and MAP sensor. Imma go borrow his code reader and see what codes I have.

    anyboy else experienced this and what did you do to fix it?
    I will wheel more, travel more, smoke less, drink less, live more

    76 CJ7, 4link F&R, FOA, Full hydro, 350, 700r4, atlas 4.3, 60 /14, 5:13's, 43 SX on Trailreadys

    Rockkrawler.org

  2. #2
    Senior Member
    Join Date
    Jul 2013
    Posts
    151
    Likes
    5
    Liked 14 Times in 13 Posts
    5.3 swap that biootch

    Sent from my SAMSUNG-SM-G900A using Tapatalk

  3. #3
    Senior Member Ramman84's Avatar
    Join Date
    Aug 2013
    Location
    HOUSTON NORTHSIDE
    Posts
    1,103
    Likes
    93
    Liked 116 Times in 110 Posts
    LS swap vato I know a guy.

    Or 4.0 swap it

    Sent from my XT1650 using Tapatalk
    89-ram w150 (aka ginger)-318/727/231-d44/9.25 3.23:1 38x16.5r15 w/2 bent rods( parts rig )
    86 dodge ram 50 (aka bridget the midget)-d44-4.56 Detroit-f /spool-r, SAS, 360/727/231 40" (goal)

    93-jeep ZJ (aka Lot LiZard)-318/46rh/231-30/35 3.73:1 33x12.5r15 blown up now

  4. #4
    Senior Member cj7's Avatar
    Join Date
    Jul 2013
    Location
    San Antonio, Texas
    Posts
    3,428
    Likes
    614
    Liked 128 Times in 118 Posts
    Blog Entries
    2
    give me a good running lq4 and wiring for free and I will swap it in.. .otherwise...
    I will wheel more, travel more, smoke less, drink less, live more

    76 CJ7, 4link F&R, FOA, Full hydro, 350, 700r4, atlas 4.3, 60 /14, 5:13's, 43 SX on Trailreadys

    Rockkrawler.org

  5. #5
    Senior Member
    Join Date
    Jul 2013
    Posts
    151
    Likes
    5
    Liked 14 Times in 13 Posts
    Lol...it's just money lol

    Sent from my SAMSUNG-SM-G900A using Tapatalk

  6. #6
    Senior Member fourwheelerjeff's Avatar
    Join Date
    Jul 2013
    Location
    Meadow, TX
    Posts
    525
    Likes
    22
    Liked 42 Times in 34 Posts
    Quote Originally Posted by cj7 View Post
    even set the air filter on fire.. (story in itself).
    oh damn
    https://www.facebook.com/JeffsOffroadEmporium/ check me out on FaceBook!

    wheeling rigs: X-Chassis #30, 2008 JKUR, 1991 K5
    tow rigs: 2002 DRW with camper, 2001 3/4 4x4, 2000 3/4 4x2 Dodge Cummins quad cabs


  7. #7
    Senior Member
    Join Date
    Mar 2016
    Location
    Katemcy TX
    Posts
    218
    Likes
    26
    Liked 97 Times in 78 Posts
    The ole mans TBI was doing what you discribe the other day minus the fire part. It turned out to be fouled sparkplugs caused by a bad O2 sensor if that helps.

    Or you might check that loose nut behind the wheel.
    If you think hard liquor is your answer..... Please talk to me.

  8. #8
    Moderator
    Join Date
    Jul 2013
    Posts
    273
    Likes
    0
    Liked 35 Times in 26 Posts
    Quote Originally Posted by snick View Post

    Or you might check that loose nut behind the wheel.
    X2

  9. #9
    Senior Member Fullsizecrawler's Avatar
    Join Date
    Jul 2013
    Posts
    128
    Likes
    0
    Liked 0 Times in 0 Posts
    Dude all the guessing will not fix it. Get a scanner hooked up to it and find out what's wrong. The TBI set up is really simple set up.

  10. #10
    Senior Member cj7's Avatar
    Join Date
    Jul 2013
    Location
    San Antonio, Texas
    Posts
    3,428
    Likes
    614
    Liked 128 Times in 118 Posts
    Blog Entries
    2
    We had a scanner on it. 12, 13, and 42 were the codes. We proceeded to troubleshoot accordingly. This aint my first rodeo with tbi motors.

    Last edited by cj7; 02-27-2017 at 09:43 AM.
    I will wheel more, travel more, smoke less, drink less, live more

    76 CJ7, 4link F&R, FOA, Full hydro, 350, 700r4, atlas 4.3, 60 /14, 5:13's, 43 SX on Trailreadys

    Rockkrawler.org

  11. #11
    Senior Member mnmstoy's Avatar
    Join Date
    Jul 2013
    Location
    Marion, Texas
    Posts
    566
    Likes
    3
    Liked 20 Times in 17 Posts
    Blog Entries
    1
    Go propane and drive It like you stole it =)
    1980 Toyota base buggy.
    4.3 V6, SM465, dana300, Propane
    One Tons, 5.13's gears, linked rear.
    39.5 IROC on H1's

  12. #12
    Senior Member
    Join Date
    Jul 2013
    Location
    San Antone
    Posts
    716
    Likes
    10
    Liked 52 Times in 44 Posts
    Quote Originally Posted by cj7 View Post
    This aint my first rodeo with tbi motors.
    No shit, you been tryinna fix it for over a year now...
    '78 GMC Longbed, almost stock

    Trusted Design Services

  13. #13
    Senior Member cj7's Avatar
    Join Date
    Jul 2013
    Location
    San Antonio, Texas
    Posts
    3,428
    Likes
    614
    Liked 128 Times in 118 Posts
    Blog Entries
    2
    Quote Originally Posted by dott View Post
    No shit, you been tryinna fix it for over a year now...
    that's cause its so damn intermittent.. one day runs like a sewing machine, next runs like shit
    I will wheel more, travel more, smoke less, drink less, live more

    76 CJ7, 4link F&R, FOA, Full hydro, 350, 700r4, atlas 4.3, 60 /14, 5:13's, 43 SX on Trailreadys

    Rockkrawler.org

  14. #14
    Senior Member
    Join Date
    Jul 2013
    Location
    San Antone
    Posts
    716
    Likes
    10
    Liked 52 Times in 44 Posts
    Quote Originally Posted by cj7 View Post
    one day runs like a sewing machine,
    Sewing machine, Vato?
    '78 GMC Longbed, almost stock

    Trusted Design Services

  15. #15
    Senior Member Ramman84's Avatar
    Join Date
    Aug 2013
    Location
    HOUSTON NORTHSIDE
    Posts
    1,103
    Likes
    93
    Liked 116 Times in 110 Posts
    I was gonna crack a joke about never seeing it work, but then I remembered I don't have a wheelable rig currently 😫

    Sent from my XT1650 using Tapatalk
    89-ram w150 (aka ginger)-318/727/231-d44/9.25 3.23:1 38x16.5r15 w/2 bent rods( parts rig )
    86 dodge ram 50 (aka bridget the midget)-d44-4.56 Detroit-f /spool-r, SAS, 360/727/231 40" (goal)

    93-jeep ZJ (aka Lot LiZard)-318/46rh/231-30/35 3.73:1 33x12.5r15 blown up now

  16. #16
    Senior Member cj7's Avatar
    Join Date
    Jul 2013
    Location
    San Antonio, Texas
    Posts
    3,428
    Likes
    614
    Liked 128 Times in 118 Posts
    Blog Entries
    2
    I will wheel more, travel more, smoke less, drink less, live more

    76 CJ7, 4link F&R, FOA, Full hydro, 350, 700r4, atlas 4.3, 60 /14, 5:13's, 43 SX on Trailreadys

    Rockkrawler.org

  17. #17
    Senior Member cj7's Avatar
    Join Date
    Jul 2013
    Location
    San Antonio, Texas
    Posts
    3,428
    Likes
    614
    Liked 128 Times in 118 Posts
    Blog Entries
    2
    just to update this.. finally found and fixed this. Happened last year at Wolf Caves.

    the issue was a broken wire going to the 4 prong connection on the distributor. bought a new pigtail and that fixed it.
    I will wheel more, travel more, smoke less, drink less, live more

    76 CJ7, 4link F&R, FOA, Full hydro, 350, 700r4, atlas 4.3, 60 /14, 5:13's, 43 SX on Trailreadys

    Rockkrawler.org

  18. #18
    Senior Member fourwheelerjeff's Avatar
    Join Date
    Jul 2013
    Location
    Meadow, TX
    Posts
    525
    Likes
    22
    Liked 42 Times in 34 Posts
    will it be ready in 3 weeks?
    https://www.facebook.com/JeffsOffroadEmporium/ check me out on FaceBook!

    wheeling rigs: X-Chassis #30, 2008 JKUR, 1991 K5
    tow rigs: 2002 DRW with camper, 2001 3/4 4x4, 2000 3/4 4x2 Dodge Cummins quad cabs


  19. #19
    Senior Member cj7's Avatar
    Join Date
    Jul 2013
    Location
    San Antonio, Texas
    Posts
    3,428
    Likes
    614
    Liked 128 Times in 118 Posts
    Blog Entries
    2
    Quote Originally Posted by fourwheelerjeff View Post
    will it be ready in 3 weeks?
    I has no idea.. but I will be

    I will wheel more, travel more, smoke less, drink less, live more

    76 CJ7, 4link F&R, FOA, Full hydro, 350, 700r4, atlas 4.3, 60 /14, 5:13's, 43 SX on Trailreadys

    Rockkrawler.org

  20. #20
    Senior Member fourwheelerjeff's Avatar
    Join Date
    Jul 2013
    Location
    Meadow, TX
    Posts
    525
    Likes
    22
    Liked 42 Times in 34 Posts
    i remembered I have to fix a brake line on the red buggy then remembered I have to fix the trailer.
    https://www.facebook.com/JeffsOffroadEmporium/ check me out on FaceBook!

    wheeling rigs: X-Chassis #30, 2008 JKUR, 1991 K5
    tow rigs: 2002 DRW with camper, 2001 3/4 4x4, 2000 3/4 4x2 Dodge Cummins quad cabs


  21. #21
    Senior Member cj7's Avatar
    Join Date
    Jul 2013
    Location
    San Antonio, Texas
    Posts
    3,428
    Likes
    614
    Liked 128 Times in 118 Posts
    Blog Entries
    2
    Quote Originally Posted by fourwheelerjeff View Post
    i remembered I have to fix a brake line on the red buggy then remembered I have to fix the trailer.

    i has more than that...
    I will wheel more, travel more, smoke less, drink less, live more

    76 CJ7, 4link F&R, FOA, Full hydro, 350, 700r4, atlas 4.3, 60 /14, 5:13's, 43 SX on Trailreadys

    Rockkrawler.org

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •